FPLtoIF Internal Server Error

Hello IFC, I was about to prepare for another flight on IF when I encountered a problem making the flight plan.


What is going on?

As many of you know, I use @Chris_S’s flight plan converter to convert Simbrief flight plans to flight plans that are more IF friendly. However, for this particular flight, I encountered an issue while I was trying to connect to the website. (fpltoif.com)

The website displayed an Internal Server Error.

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at webmaster@fpltoif.com to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

Possible Ways

I have tried restarting FPLtoIF and have tried using different devices. All of the devices I have tried it on showed the same message. I have also switched from WiFi to cellular to see if that would do any help, but it just gave me the same results.

Do you guys also have this problem?

I don’t know if this is a problem with my side or if it is a problem with @Chris_S’s side. If it is a problem with my side, then that means the rest of you guys still have the website working. If it is a problem with my side, then that means you also have the same error.

So, did you guys also encounter this server error?


If this is a duplicate, you can lead me to it and if it does answer my question, this can be closed. However, I have searched and nothing showed up.

Nope I have never had such issues

It’s working fine with me. Could it possibly be you?

This is what I see on both my computer and my phone

I have seen this before. I do not remember how I fixed it though.

I have tried reloading before but nothing happened; it just kept showing me the screen

I’ve had this happening to me before as well. If I remember correctly, all I did was just to refresh the page and it began working again… don’t know if that solve your issue :/

Yes, I’ve tried that.

1 Like

On your Phone, try using Cellular Data instead of WIFI and see what happens?

See the original post

1 Like

Browser, try switching that and see if it works using a different one?

Perhaps a message to @Chris_S or awaiting his reply here may help. It’s his site, he may know how to fix it up for you.

1 Like

Ok so Safari seemed to work but not Chrome

Wonder why…

Thanks :D

1 Like

It works on Safari, correct?

Yes, it does work on Safari

1 Like

Okay, I’ll let Chris check in on issue with Chrome, in the meanwhile try and see if other browsers work.

I can say that all browsers: Chrome, Safari, Bring, Explorer (Windows 7), Microsoft Edge (Windows 10 Home), Firefox and Opera works for me right now. Check on some of these to confirm whether they are working or not for you.

Anyways, glad that it works at least on one browser, hope you get your flight under way safely :)

2 Likes

Sorry gang, I have been working on the site today. It should be up now.

The table that holds historical plans that are used for the random flight generator grew very large and the random part of the code was struggling and ate up server resources. The code has been updated and you should notice a performance improvement when generating a random flight.

PS… you can also use randomflightgenerator.com as a shortcut to the random page. :)

3 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.