Foreflight Not Connecting

Whenever I tried to connect Foreflight to Infinite Flight, it doesn’t connect.
I’ve done the following:

  • Made sure I’m on the same network
  • Made sure Foreflight Connect was enabled on Infinite Flight Settings
  • Used separate devices
  • Started a flight then tried to connect to Foreflight
  • Updated all devices

So far none of this has worked. Any other ideas?

Is your Infinite Flight up to date as well as your Foreflight?

Yep. Everything is up to date.

Do you use Foreflight for other apps like X-plane etc…

This post was flagged by the community and is temporarily hidden.

Are you on a public (school, work, etc.) wifi network? Have you gotten IF to connect to other apps?

Nope. Only for IF.

No, I’m using my home wifi network. And yes, I have gotten IF to connect to other apps like IF Operations and IF Assistant.

Maybe try to restart both devices if you haven’t. I have ran into this issue multiple times before where it randomly just wouldn’t start but after a few minutes or to even a few days it would work as it should

Agreed on this one. Start your flight in IF, then restart ForeFlight. This usually solves it for me.

1 Like

Just restarted both devices, didn’t work. Like you said, I’ll wait a couple of days.

Feel free to shoot me a DM and we can get to the bottom of it 🙂

Just did that too, didn’t work either. I also uninstalled and reinstalled Foreflight. That didn’t work either. Do the devices need to be the same? Like an iPad and iPad, or an iPhone and iPhone?

Alright man.

Make sure foreflight has access to the local network in your settings

If you don’t have this option, you need to uninstall foreflight and reinstall it and then a pop up will appear when it tries to connect to the local network.

1 Like