Fly-by-wire buttons work, but the controls don’t

I just recently got the Fly-by-Wire add on and it doesn’t seem to work. The buttons work just fine on the aircraft but the flight controls aren’t responding. No yoke, rudder or throttle. If it’s with the control settings, nothing appears with devices in settings. And if the problem is in the settings, I don’t know how to configure it correctly. Asking for help here :)

1 Like

Thanks for purchasing the app! I’m sorry to hear you’re having some trouble.

Infinite Flight needs to be told which control axis is which. Try these steps:

  • Open Infinite Flight and spawn anywhere, in an aircraft.
  • Open up Fly-by-Wire and press Reconnect. Wait for confirmation you’re connected.
  • Hold Fly-by-Wire in front of you, the way you intend to use it to fly. It’s easiest to do setup in yoke mode.
  • In Infinite Flight, navigate to Settings > Controls.
  • Under the Key/Axis column, tap “Roll”. It should say “Move Axis on Device to Assign”.
  • Move Fly-by-Wire side to side, to show Infinite Flight which axis is the Roll axis.
  • Repeat for the other three axes, either by moving the device or moving the sliders.
1 Like

Tried just that and it worked perfectly. Thanks for the help! Already have tested it out on a few aircraft and I love it a lot.

2 Likes

Glad to hear it :)