Flight glitching out

While I am flying(mostly while I’m controlling and or final) I will go and try to tap on a command in the ATC menu and it will start flashing. And once I click out of the ATC menu and tap the menu button my whole interface goes away. What is wrong?

1 Like

Have you tried any troubleshooting steps yet? If so, please list them so we may better assist you.

If you have not tried anything, the first thing I would recommend is a restart of the app and/or your device.

I have tried almost every single one. Restarting the app won’t work. And once in a while restarting my device will work occasionally.

Hmm…have you tried reinstalling the app?

Yes, I have multiple times. This glitch just happened to me while i was on final.

How much memory does your device have free?

You may be hitting the limit and having problems because of it.

Which device are you using?

I have over 16 GB free on this device. And it’s brand new. I got it just for infinite flight.

I am using a iPad 5th gen.

Do you have a stable internet connection? What is your ping and upload/download speeds?

I have a constant download speed of 20mb/s I’m connected to the internet on multiple devices and it doesn’t cut in and out on them. Also while I’m flying I rarely have the check mark go to red.

What are your graphics settings set to?

Set all high, but when I’m controlling I turn them all the way down and it still happens.

It may be an issue on your device’s side. Have you tried re-installing iOS through iTunes?

I haven’t I can gladly try it though.

Let us know if you’re still having problems after trying that :) make sure to set up the device as new. Restoring from a backup can also restore the bug.

The glitch is still happening.

Hmm…thanks for trying that, sorry that it didn’t work.

@schyllberg any ideas?

Was just looking at this, and i have a vague memory of seeing a similar report somewhere with a solution.

I’ll dig.


From what i’ve been able to find, a reinstall did help.

Just for the sake of it, let’s try this.

  • Uninstall Infinite Flight from your iPad.
  • Turn the iPad completely off, and then back on again.
  • Reinstall Infinite flight and try again.