Flight controls are getting stuck

Hello,

My aircraft flight controls, Aileron, and Pitch controls get stuck in a position in 5-10 mins after starting my engines. If engines are not ‘ON’, flight controls act normally.

I started to face this issue after joining the scenery editing team.

I tried Uninstalling and Reinstalling the app, resetting controls to default, I also restarted the device and tried clearing cache and in-app data.

Device: Redmi 10s
Operating system: Android 12

Thank You

2 Likes
1 Like

Calibrate before you take off! Go to the three dots below, then press calibrate on the left hand side.

👀
Controls gets stucked in a position after few mins I start my engines, it’s not about calibration of device or takeoff

Hello,

Here is something that might help.



1 Like

I tried that too, problem still exists

Maybe the gyro of your device

During flight have you tried going to controls, under settings to check if it shows accelerometer movement. It shows you the % movement and bar graph of the amount of movement, if accelerometer is working. But if you have autopilot on when you do this, you will see no movement. So with autopilot off does accelerometer show a response?

1 Like

Accelerometer dose not move, most of the time it gets stuck after pushback when I start my engines

Does it ever stop working when using other apps or functions on your device?

Have you approached someone senior in the scenery editing team about this to see if there is any other occurrence? I guess scenery editing might require accelerometer input to move between airport positions? If so, does your accelerometer function properly while editing?

Ok, so I’m out on a limb speculating now. So I’ll just leave it there. I can’t think of anything else. I hope for a solution.

1 Like

I have been in contact with a staff, he said scenery and controls are not related to each other

1 Like

If you have verified that none of your other apps experience accelerometer disruption, all I can think of is re-installing IF. And testing that fresh installation.

Though of course you lose your replays and other such data (a way to save such data?).

I assume the scenery editor is appended to the basic IF installation(?).

If you could isolate that the fresh, basic IF installation either is free of the problem or not, that would be useful info in trying to sort out a cause:
1)device
2)IF
3)IF with editor (though apparently no known issues?)

Are you still facing this issue @Sierra_Golf

1 Like

Yes sir, still same issue

My device accelerometer is glitching out @Rohann @adit

Do you mean you found it’s not working properly even outside of IF?

edit: or maybe you mean you still can’t isolate it?

btw I had this happen once in the last 24 hours. Quite unexpected. It didn’t resolve even leaving the flight and returning. But did resolve exiting the app.

1 Like

Time for this @Sierra_Golf

1 Like

Yes outside IF

1 Like

Should I mark this as a solution 😂

1 Like

yes Sure :)