Flaps not working on the Embraer 190

I was just doing some pattern work at KNUC on TS1, and I noticed that the flaps on the E190 did not do anything at all. I know the aircraft needs a rework, but I’m pretty sure that the flaps worked last time I used it. It was a bit of a problem, as in order to land I had to land at about 160 knots. Not realistic for that aircraft.
Sorry, I can’t provide screenshots because it isn’t the sort of thing that screenshots can be used to explain.
Anyone else had this problem?

Weird, last time I used it they were working fine.

Can you provide a screenshot or two?

1 Like

Just to clarify, by using the term ‘not working’, are you saying that they aren’t even deploying, or are you saying that they appear to deploy (both on the control panel and visually) but they appear to have no effect on the flight characteristics of the aircraft?

1 Like


Ok, so here I am doing the same speed, at the same altitude, but in the first screenshot I have no flaps, and in the second one they are on full.
I know you can’t see that they are on 0 on the first one, but I can assure you they are.

I think he means an external view as well ;)

When I look at the aircraft, they are moving when I want them to move, but they don’t have an effect on the aircraft’s movement.

On the external view, they are working, but they are not having any effect.

Are you overweight? You might be over MLW

Try restarting the app, delete and reinstall Infinite Flight, than try again

2 Likes

Ah, I just restarted the app and it worked. I should have done that before asking here I suppose. Thanks.

1 Like

Please, don’t sweat it, glad it helped ;)

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.