Faulty LNAV & HDG

Hello IFC,
I was doing a flight on the Expert Server from KDCA-KORD, in a F9 A320. I came across an issue that has happened before, most recently in the previous flight I did. Due to the issues I had to quit as it was impossible to fly.

LNAV Issue = Won’t stay on course
HDG Issue= Occasionally wont move when I try and switch it.

Say my heading is 275 degrees. If I want to switch my heading to 280 degrees, and I tap the HDG to switch it, it won’t do anything, and I will stay on the same heading.

I also have another issue with the HDG. It won’t stay on the heading I assigned it!! This is frustrating cause it is impossible to fly the plane.

Issue Reproduction:
Not been able to reproduce

Time of occurrence:
Approximately 8:20 P.M. CST

Device: IPad 9.7 inch 2017 model
IOS: Up to date
If a dev or staff member could get back with me that would be great! Thank you!

2 Likes

I managed to get a screenshot but doubtful that it will do any good.

1 Like

In that photo you don’t have NAV on. Also may be because you edited the FPL, it will send you to the start. Just delete that waypoint and you’ll be back on track.

Can u get a screenshot of the HDG issue? I don’t see any problem.

This reason you may not be able to change heading is because you are on NAV mode, it will not allow you to change the heading.

3 Likes
  1. I turned LNAV off because it was not working
  2. No, I quit the flight already
1 Like

Were you on nav mode when you tried and shifted the heading?

1 Like

No, I was not. I tried to change the HDG long after LNAV was off.

The LNAV follows whatever leg of your flight plan is active, which would be purple on the map. This can be modified from the flight plan menu, simply push the active button for whichever leg you are currently on. (normally the sim will adjust it automatically, but it doesn’t always).

Based on your screenshot, the fact that the leg is white tells me that the incorrect leg is active. Try what I suggested above and let me know if it helps.

2 Likes

Like I said, I already quit the flight, so I can’t do as you say.

So has this happening multiple times then, I would suggest a reinstall.

This is the second occurrence of this issue. Last occurrence was Thursday, which was the last time I flew.

I don’t think this is a sim issue, I think you might be misusing NAV mode a bit.

Can you try starting a new flight, with a flight plan and playing around with the active legs with the LNAV on? I think you will see how the active leg affects the LNAV, and you will understand how to correct the problem in the future.

1 Like

I understand how it works. Never had an issue with it till this week.

I’ll try to re-explain. On your map, the lines between each waypoint you fly is represented by a line. In your photo, those lines are white. If the line was purple, it would mean that the leg was active. The LNAV automatically flies the leg that is active, meaning if the wrong leg is active, the plane will automatically turn to fly the wrong leg - even if that leg is 2000 miles away.

I think the reason your plane is banking left is because it is trying to fly the wrong leg, which is obvious from the fact that the leg your plane is flying based on your photo is white, and not purple. If you open the map, go to flight plan, and set the active leg to the one (the line) that your plane is supposed to be flying, then the LNAV should fly the correct leg.

(If you need a screenshot or more clarification, I would be happy to do so)

1 Like

Strange. I remember half of my FPL was white, and half was purple.

Just so we’re all on the same page:

  • Heading cannot be adjusted while NAV or APPR is enabled.

  • If NAV or APPR is enabled and you try to change the heading, nothing will happen. And from the description that you gave this is what sounds like is happening.

  • If your waypoints are too close to each other, your LNAV will literally fly in circles trying to intercept that waypoint. Its best to delete any waypoints that are within 10nm of each other. That should provide enough time, while at cruising speed and depending on the turn, for the aircraft to cross over the next waypoint.

And from the looks of it as noted by another member, you have your heading set to 180 and it is evident you are turning from 271 to 180 in the correct direction so that appears to be normal.

If this happens again, go to in the settings -> general -> show touches (turn this on) and create a video. You can upload the video unlisted if you’d like to youtube. This would better assist us in determining if there is an actual issue.

3 Likes
  1. Heading cannot be adjusted without NAV/APPR enabled
  2. Vise versa
  3. I understand
  4. I’ll do my best
1 Like

I don’t know what you want us to say.

The active leg in your picture is not the leg you’re on. So, yes, you have LNAV on, but it’s doing exactly what you should expect it to do, flying the active leg. If you want it to fly the leg you’re on, make that leg active and it will do it.

There’s nothing out of the ordinary in your image

1 Like

That’s why I said my picture wasn’t effective. It’s hard to explain, sorry.

The picture is clear, just looking at the map in the photo tells us that the wrong leg is active, which explains all of the issues you are having.

Oh ok. If it happens I’ll send a video.