F/A-18 Gear Glitch

So for the first time ever my F/A-18 let me down. While flying around the Amsterdam region (yes I don’t have Global yet), the gears I guess tried and put an invisible suit on or something. There magic trick must have worked cause I am "Thunderstruck!"

IPad 2
IOS 10.3.3

nah its supposed to bel like that since the fa18 is a relatively old aircraft

It has not ever been like this and I have flown this aircraft about 56.7 billion times…

it’s always been like that

Not for me…so strange

What on earth are you trying to say in this post?

1 Like

he’s talking about the gear “animation” on the fa18

That my gear is not showing up

Guys…well…I restarted the app and…they appeared again. Thanks for the info. @Brandon_Sandstrom yes I know I just wanted it a little entertaining. Don’t know why I didn’t think of restarting the app in the first place but oh well thats the solution and thanks you 2 for the help and info :)

1 Like

Before it worked again it looked like this

This is a common glitch. I am positive there is already topics about this, this glitch usually happens in replay mode.

This is because the F18 is a older outdated model compared to the F16, F22, or F14. For now you will have to deal with it and wait for a F18 rework. ;)

1 Like