Error uploading IF screenshots


I get this error uploading screenshots from IF, shot in 4x resolution scale in app.

iPad Pro 9.7
iPhone XR

Other photos/screenshots like this 👆 works fine

Hmm, this only happens to me when the file type is unsupported. Not sure if that’s what it means :L

1 Like

Seems like something went wrong when discourse tried to use ImageMagick’s convert command-line utility to convert your photo. It’s weird though, seeing that lib/upload_creator.rb, the script responsible for uploads, has been last updated on September 22nd, and the file responsible for running the shell command (lib/discourse.rb) was updated all the way back in August, so you might want to do some basics like clearing your browser cache just in case (because it’s not like any of us would be able to do anything about an issue in Discourse or ImageMagick)

1 Like

I did a restart of device and tried again. No luck.
I’ll try some other things.

Looked into it a bit more, it seems for some reason discourse thinks that the .jpg infinite flight gives out is .png, but then even so the ImageMagick’s convert function works even if the input and output paths are the same (just tested locally on an IF screenshot with the exact arguments that discourse uses). I’m afraid that’s indeed something discourse related.

1 Like

Ok, thanks for checking Mr. Nikitin

4x resolution works fine for me.

iPhone 12 Pro, iOS 15.1 via DiscourseHub

1 Like

I’m still on 14.8.1. Could that affect anything?

Problem with the file, same error here. [?]

1 Like

Definitely could. I can’t see what else to be honest.

1 Like

Ok. Cam is informed and will check. But I can update to 15.1 and try again

Oh i know. He partially dropped it on me since he’s busy creating bugs for next release (:

1 Like

Got it. I’ll update both devices and try again

1 Like

Don’t worry. iOS 15 isn’t that scary. Just a little bit at first ;)

Oh no… That didn’t sound good

So… If I edit photos in the iOS edit function (adjust exposure etc.) I get the issue. If not, no issue. Nothing to do with iOS version as far I can see. 🤯


Are you saving them as a new photo or as the same?

As the same

Try saving as new and try uploading. Because when you save the same, a bunch of edit & iOS specific meta data is also saved which enables you to undo those saves. I would say that is an issue for Discourse.

1 Like

I don’t even know how to save an edited photo as new lol