Error Logging In. Invalid Credentials

I can’t log in to Infinite Flight. It seems that this issue is becoming more and more widespread. Moderators I need help!


I have the same problem, I can´t join to the event

Perhaps maybe too many people are trying too connect.

Having the same issue

Yup happening to me as well. Ive tried connecting on both WIfi and Cellular and the same thing happens. Saying invalid login credentials. Facebook is my log in. Please help out the mods and also say if you use facebook to log in

1 Like

Me too,ugh.

I use Google to log in.

1 Like

Its google too, I use my google account to login so it’s not just Facebook.

1 Like

Having the same issue :(

Same here.

Same here with my IPad logging into google.

1 Like

Got the same issue.

So many people with this problem :0 We need to fix it before @Dylan_M 's event!


We are aware of the issue and are looking into it.


Okay great! Thanks!

Same here as well- Let’s not spam the thread with “same here” and let support staff work on the issue!

“Infinite Flight was unable to connect to the server. Try again?” instantly appears with a yes/no - after selecting yes, you are eventually given the message “Invalid Credentials” after a while saying “Connecting…”


I tried connecting on both of my iPads, but it says “Connecting” and “unable to connect” on both devices. @Pilot_urp seems to also be having the exact same issue as me…

This is not a server restart, is it?

Widespread issue.

I’m sure this issue will be resolved shortly

Support staff is on it rn

1 Like

Possible server restart?

We are currently experience issues with one of our primary databases which could be causing issues when trying to connect to your account.

We are working as hard as we can to get everything back as soon as humanly possibly!
Sorry for the inconvenience!