Error Code 7

Hey all. I’ve been facing issues opening the app for the past month or so. I’m usually met with an Error Code 7 and I am unable to enter the app.

Device: Samsung Galaxy S8+
Operating system: Android 9
Infinite Flight Version: 24.1/latest
Connection Type: WiFi
Country: Singapore

Steps tried and Notes:
Reboot Device:
Does not work. Tried multiple times.

Switch between network types:
Switched to cellular/hotspot. Works, however app does not load when disconnected or connected to WiFi. Additionally, when switched back to WiFi, Global Server is disconnected for long periods of time.

Try a different network:
N/A.

Toggle airplane mode:
Does not work. Turned on airplane mode for about 40-60s each time and turned off, causing it to automatically reconnect to WiFi. App does not work.

VPN/Proxy:
N/A. None used.

Reset device network settings;
Does not work. Reset all network settings and reconnected by entering WiFi password. App unresponsive.

Update WiFi DNS settings:
Changed DNS 2 to 8.8.4.4. Disconnected and reconnected to network. No change.

The app runs perfectly fine on iOS and on the same network.

Additionally, I tried to delete and re-install the app. Does not work.

Was sometimes met with error code 8, however it goes back to the usual loading screen when “retry (?)” was pressed.

1 Like

Hi!

Sorry to hear you’re experiencing issues.

The S8+ is from 2017, so it’s really getting old and that’s something to take into account.
Since it’s running Android 9, currently the minimum version required for Infinite Flight, it should however still work.

Error Codes 7 and 8 usually indicate that there are network related issues.
Since there currently aren’t any server issues on IF’s side, and since your other device isn’t having any issues, it probably means that it’s a local network/device issue.

Does this mean that the app works as expected when connected that way?

When disconnected IF isn’t able work at all. It needs a stable connection to work properly.

It’s impossible to tell what might have broke on the S8+ to cause it to not be able to connect to the servers.
Trying another Wi-Fi network at another location might really help to figure out what might be going on.

Personally I have experienced network connection issues with Android devices while connected to my Wi-Fi access point.
My iOS/iPadOS devices were not having any issues whatsoever.
Restarting the Wi-Fi access point solved the issue.
Maybe you could try that?

From IF’s side, there doesn’t seem to be anything that can be done.

1 Like

Yep. I can join multiplayer and use the app normally.

That really points to the local network.
I added this part to the post a little later.
When possible, give it a try.

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.