Error code 7

I keep getting an error code 7. I deleted the app and reloaded it but it still continues to give me the same error. When I downloaded the app it said the new version was only compatible with IOS 13 which my iPad is only updated to 12.5.5
Is there an IOS 13 update I just haven’t got yet? I’m paying the $10 subscription thing per month but if I can’t even use it then I’m wasting my money.
Anyone else have this issue?

1 Like

Sorry you are having issues connecting to our servers. Please understand that while devices may be the same, the network configuration may be different between users.

Please try the following to resolve your connectivity issue:

Reboot your device

This should always be the first step to resolve any issue. Sometimes the server issue is temporary so waiting a short period of time and/or rebooting may help.

Switch between network types (WIFI/Cellular)

If you are on wifi, try cellular if you can. If you are on cellular, try a wifi connection and see if it is any different.

Try a different network

For troubleshooting, try a different network and see if the results are different.

Toggle airplane mode

– Shut down IF
– Go into airplane mode on your device for 40-60 seconds
– Turn airplane mode off. This causes your device to reconnect to your network and solves the problem for some.

VPN or Proxy

Ensure you are not on a VPN network or behind a proxy. These will often block the necessary UDP ports for a successful connection to the live server.

Reset device network settings


Go to Settings > General > Reset > Reset Network Settings. This also resets Wi-Fi networks and passwords, cellular settings, and VPN and APN settings that you’ve used before.

From the Home screen, navigate: Apps icon Apps icon > Settings > Backup and reset
Tap Reset network settings.
If applicable, enter the PIN, password, fingerprint or pattern then tap RESET SETTINGS again to confirm.

Update wifi DNS settings

In some cases you may need to update your devices DNS settings on wifi to use google’s DNS.

Here’s how to change your iPhone’s DNS servers:

  • From the iPhone’s home screen, tap Settings.
  • Tap Wi-Fi. The available wireless networks in range of your iPhone appear, as shown below.
  • Find your wireless network in the list, and then click the arrow.
  • Tap the DNS field.
  • Delete the current DNS servers, and enter the new DNS servers. (If you enter more than one DNS server, be sure sure to separate the servers with commas.)
  • To use Google DNS, enter and
  • Re-launch IF


  • Open the Settings on the device.
  • Select “Wi-Fi”.
  • Long press your current network, then select “Modify network”.
  • Mark “Show advanced options” check box.
  • Change “IP settings” to “Static”
  • Change DNS1 to
  • Change DNS2 to
  • Press “Save” button, disconnect from the network, and reconnect for changes to take effect.

The DNS can only be changed while on WIFI.

Please make sure you try all the listed steps as described above.

If you have tried all of the steps above, please reply to us with the following information:

  • Your device model
  • Your Infinite Flight version (This can be found in the top left corner after tapping “About” in the app)
  • Connection type, cell/wifi. If cellular, please name the network provider (Verizon, T-Mobile, etc)
  • Country you’re currently in
  • Please list any of the steps above you have already tried and their results.

Thank you!

Thank you for your response.
I have tried rebooting my device and going from wifi to cellular I few different times. I will try the airplane mode and resetting the device next.

Ok so I just tried resetting my network settings and toggled airplane mode and that didn’t work either. Still giving me the same error code 7. I don’t know what I VPN or proxy is and I don’t know how to update my wifi settings.
My device is an IPad Mini 3
I’m currently on AT&T I can switch between data and wifi, I’ve tried both. I can’t get into the app to tell you what version I am running. I am in the US.

Error Code 7 simply means that the app is not able to reach our servers.
As we don’t have any ongoing issues here, there’s something blocking on your end.

Are you using AT&T on both connections? Cellular and WiFi that is?

No the wifi is through xfinity. Which I don’t believe there is an issue there because we are all able to access everything else on our phones and iPads with the wifi. Could it be my version of IOS is preventing it from working? Are the new iPads running IOS 13?


iPad Mini 3 lost support during ADC 2019 meaning it’s max OS is 12, and since the user is attempting to use a new version of the app which requires iPadOS 13 or higher, this might be the issue at hand here

1 Like

All modern Apple handhelds run iPadOS15 and iOS 15 or newer.

No, it’s not since 20.3 and all versions thereafter are still supported.

1 Like

What version of the app is the user running in this case?

Not relevant since Error Code 7 would not show up regardless. Unsupported versions will display something else.

When you’ve switched settings, did you restart the app in between? Not just tapping the “Retry” button in the app?

Yes I restarted the iPad and closed all open apps and restarts it. It’s 96% loaded now. It’s taken almost 30 minutes to do it but we are almost there. Once I get in I’ll reply with the version it is running.

96% loaded of what? Is it downloading the navigation database or what are you referring to?

Yes sorry I should have specified. I didn’t get an error code this time it seems to be trying to work.

1 Like

That’s good!

A bit worrying that it’s taking such a long time though. The navigation database is quite small.
The issue here could be that our content delivery network is having some issues in your area. So it could just be temporary.

Ok that would make sense. It says it’s downloading the airport data now and it’s been at 96% for probably 20 minutes now

It finally loaded. It says I am running version 21.5 (1081)-B30929B3- apple iPad 4,8

What ever all of that means. Thank you for your help by the way

1 Like

Then you’re on the previous version. 21.6 is the last one but we require iOS 13 for that. Unfortunately your device isn’t compatible with that but it’s fine. It should not affect your connectivity regardless.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.