Error "authorizing application access" on Discourse app

I’m having difficulty authorizing access to my IFC account through the Discourse app on my Android phone. Authorising access would allow me to receive notifications and link my IFC account to the Discourse app. I’ve tried authorising over the past days to no avail.

How are you logging in? (email/password, or one of the social network options)


The app probably can’t communicate or support with the program/forum builder this forum was made from.

By reading the reviews on the Google play store. It’s not just you. It’s probably how the developers made the app which is shown with the 2.9 star rating.

Google account

@James_Browne I have used the app previously like this and it has worked fine.

@EyesSkyward so I just had ago and it worked perfectly

Also, the forum builder/host for IFC is Discourse. So it should be perfectly compatible.

@EyesSkyward for infinite flight forum?

Yes. And the Discourse Meta forum.

Did you try removing it and re adding it

I just tried. It takes me to the exact same authorisation page which displays the error.

How many things do you have connected to the app?

Just IFC is added to the app at the moment

1 Like

Ok well it’s interesting because it’s not your account but the software the forum is built with. But camron will know more

Ok, so I just uninstalled and installed the app, and it seems to have fixed itself. Odd. Maybe it needed a refresh after using my old account on the app a year ago. Thanks for the help.

1 Like

Ok well I was actually about to say reinstall but you got to it first

Now you know what to do for next time. 🙂

Hopefully there is no next time. Discourse needs to rework the app.

1 Like

Especially at 2.6 stars on the play store