Elevator pitch won’t go above 36 degrees

Here’s the problem. I was flying from OMDB to ZGGG in a China Southern 788. Everything was normal until final approach when I disengaged AP and took manual control. The moment I disengaged AP the nose when straight down so I pulled back on my device as much as possible but it seemed like my sensitivity was on the lowest setting because the nose was coming up extremely slowly. In the end I had to turn back in AP and use the vertical speed feature to land. After landing I checked my settings and it turns out the max elevator angle I could go to was 36 degrees. If I pitched my device any steeper the pitch would start to go down again. This explains why I had trouble leveling the plane but the mystery is why my controls were limited to 36 degrees. Like I mentioned before, everything until then was normal. I took off and the controls were working fine. I left the device while I was in cruise and when I came back it was like this. This is also not the first time this has happened. It’s happened on multiple occasions on different aircraft models. I don’t know why this is happening I hope there is a solution. Thanks.

Here’s a photo:

1 Like

Perhaps you accidentally recalibrate while the device was in an awkward position? That would explain the problem

Have you checked in General that you haven’t got it set to low under sensitivity.

This would explain it but even after I recalibrated the controls on the ground while placing my device in the position that I normal put it in, the problem still didn’t fix itself.

What device are you on?

I have seen this before where when the app starts that it is not capturing the accelerator readings as much as it should. Normally a reboot will fix the issue.

1 Like

That’s not the problem either. I always hit default for the controls before each flight. And the problem is fixed automatically after I exit the flight. I loaded into a flight with the exact same plane (CS B788) and the problem is not there anymore.

The problem always appears at the end of a flight

2017 iPad Pro 10.5 is my device

1 Like

This doesn’t have anything to do with the physics of IF or how I fly in the sim, it’s a problem with the controls. Please read the description before posting something random. I appreciate you trying to help me out but please

What have you tried to solve the problem?

Are you calibrating before you turn off auto pilot?
Did you reboot your device?
Did you reinstall Infinite Flight? (Please backup any saved replays as all will get removed with a reinstall)

1 Like

Sorry I misunderstood the problem.

I did recalibrate before turning off AP. I recalibrated again after I noticed the problem but that didn’t solve it. I restart my device every time before a flight longer than 2 hours. I tried reinstalling IF after the same thing happened yesterday on a 77W

So during cruise, you can pause it and go to the control settings and it behaves as it should with a full range of movement?

But then as you get closer to landing it doesnt? Does it happen only after you turn off AP? Can you do a screen shot of your HUD right after you turn off AP and calibrate?

After you turn off AP and calibrate, go to the settings page and see what it shows.

You can also try hitting “Restore Defaults” on the controls screen.

  1. Yes everything was fine during cruise. The elevator controls worked as they should.
  2. I usually have AP on until 6nm out from the runway threshold. Yes, it only happens if I turn off AP, if I have AP on, everything is fine.
  3. I can put a screenshot of my HUD from the replays but I can’t recreate a 7 hour flight right now so I won’t be able to take a screenshot of the settings.
    The nose was down because I was still trying to recover from my dive.
  4. I hit that multiple times but it didn’t fix the problem

What happens if you turn off AP at cruise?

Can we get a screen shot of your HUD controls?

I did not turn off AP during cruise on this flight but I did once on a pervious flight which had the same problem as this one and everything was fine. The nose didn’t pitch down or anything.

I’m not seeing a reproduceable scenario which is why I am asking. If you turn it off at cruise does the same thing happen.

I’d still like to see the HUD controls at the time you disable AP

Trimming out the aircraft will make the load easier. Depending on how much you weigh, the elevator won’t be as effective. Set trim to about 25% before deactivating AP. After trimming, calibrate the aircraft, (I do it more than once, for both good measure and a habit), and proceed on to greasing the runway.

And if that doesn’t work, go to the control settings, and in the bottom left corner, press restore to defaults.

Attempt the following.

  1. Restart your iPad (Turn off for 30 seconds then turn back on)
  2. Re-Calibrate
  3. Reinstall (Back-Up Replays)
  4. Soft Reset your WiFi router (Sometimes works)

Make sure to mark me as a solution if it works.

If not let me know and I will try my best to help it work.

The OP has already tried these. Please read before posting. :)

1 Like