EGLL and a Few other Airports not loading

Hi Everyone.
I have downloaded and redownloaded IF severally and still can not load EGLL. It just stays on the loading page. And I can’t exceed an hour of flight time without an app crash. Please help
PS, I use an iPad Air 2

Do you have a screenshot?

Is your Wi-Fi service good?


Have you cleared cashe too?

My WiFi service is extremely good. I have cleared cache.

Could you send a screenshot of the issue please.

People let’s not throw out random fixes that might work without knowing the actual problem

How long has the airport issue been occurring for?
And do you restart your device before each flight?

Yes I do and I’ll send a screenshot now.


It never leaves this screen

Have you tried

  • Restarting your device
  • Turning your Wi-Fi on and off

And I’ve wasted so much data on constantly trying to uninstall and the install again

Done all of this. Done it repeatedly

Is this on Live or Solo?

I had the airport problem for some time, all I did was wait it out

On live 🤷🏼‍♀️🤷🏼‍♀️🤷🏼‍♀️🤷🏼‍♀️

Oh for how long did you wait?

Well I repeatedly tried to spawn in Heathrow but gave up, after 4-6 hours, it decided to work again.

Some other things that may help:

  • Have aircraft count down to low
  • Have scenery quality on low

Oh wow. So do you suggest I waste my data on downloading planes again? Or wait for the airport to load