Does not load KMIA airport

This error has happened to me 2 times and between the flights I restarted the app and the device. But it was no use because it happened again.

iPad Air 3 generation
IF 22.4

Did you try clearing scenery cache?

It might be issue with the scenery. Have you tried to clearing your scenery cache?

I just did it, I’ll see if it’s solved, thanks for the advice :)

Clearing the cache did not work for me, I have already 3 flights and the same thing happened to me on all three

yes and it didn’t work

I think it may be more of a problem with the airport because it only happened to me at KMIA

Try changing your rendering settings from high to low then back to high and see what happens

on the flight or before entering?


Can you please try these steps and follow the steps in their specific order:

To resolve this issue, please try the following steps:

Step 1

Re-launch Infinite Flight (make sure you stop it from running in the background first)

Step 2

Before starting a new flight, go to Settings > General > Tap “Clear scenery cache” (it’s at the bottom)

Step 3

Start a flight (try on Solo first)

Also noteworthy, ensure you have a strong internet connection and make sure you have storage available. The 3D at KMIA is quite extensive, not as much as KATL as far as density, but it’s a large airport with a lot of buildings and objects.


Thanks for your advice but I already discovered that the error was in my internet connection, It did not reach me with enough power, and in airports such as KMIA or KATL if I do not have the Wi-Fi bar at maximum or almost at maximum, this error occurs.