Didn't receive the 21.3 update

Am I the only one that didn’t receive the update?

Is your device compatible?

Hi, have a look at your App Store for and search for infinite flight there. You will usually find the update button then

1 Like

I’m using Realme 5i with 64bit processers
Snapdragon 665 4GB ram

I’m sorry but I’m using Android device 😅🙌

I mean play store then 😅

1 Like

This what they told me

What device are you using?

Sometimes it take longs for me to have the uptade… But in your case it’s very long 2 days…
Did you tried to re-install the app ?

1 Like

Ah sorry I missed that

I have no clue your device is 64 bit, so I would guess the update just hasn’t reached your region

1 Like

How old is your device?

1 Like

2 years old and I bought it as new device

That’s strange then. It’s been 2 days since release and it’s still not there… if it doesn’t arrive in the next 48 hours, you might wanna contact support

1 Like

Alright thanks for helping 🙌

1 Like

This is down to the Play Store unfortunately. It looks like your device is supported so that isn’t the issue.

I would try:

  • Close the Play Store, then clear the cache for it in settings (it’s in the “Storage” section in the app’s section in settings usually)
  • Check you’re on the right account, you may need to switch to another Google account if it was purchased on another

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.