Device not compatible with this version

Hi support & everyone who chipped in to help. After all the advice from support & u guys, i located the bootloader & unlocked it. Now i have my infinite app back installed, what a relief!

Thanks guys

3 Likes

Hello @Tayo_Olutumogun!

Have you unlocked your bootloader? If so, that would be the case.
We’re using Google Play Protect, which does not approve of unlocked bootloaders for example.

More about this here:
https://support.google.com/googleplay/answer/2812853?hl=en

I am experiencing the same problem too… despite my device being 64-bit.

and what is a bootloader?

As schyllberg stated it might be a boot loader issue. But given we are talking Samsung here, I will just resend my PSA about S devices (Specifically tablets).

Being the Samsung Galaxy S8, I highly doubt that it’s running 32bit. This has mostly been present on the lower end A series devices. None of the S devices have yet.

We’ve added some extra information to help you diagnose this at the bottom of this page:

Yea the problem however was Samsung was limiting 64 bit devices to a 32 bit OS

It was an example. Custom ROMs and several other things may be the issue.

Oh oops, will amend 😅

The following message is from another topic regarding the same problem:

I checked my Google Play Store five minutes ago to see that my device is not compatible with 21.5. I was waited long for the update to see that message and i am disappointed by that.

Before anyone asks:

Device name: Huwaei Y7A
Processor: Kirin 710A (64-bit)
Memory: 55GB useable out of 128GB
Android Version: 10 / EMUI 10.1
OpenGL: ES 3.2

Can anyone help?

If you read the previous replies in this topic, you’ll get the answer :)
Here’s one:

(General | Infinite Flight)

Hi, i must confess I don’t know what a bootloader is? How do i unlock? But i’ve been playing infinite flight on this phone since june.

Have a look here. Bootloader was an example :)

Well after extensive researching,

my device is on the certified list of Play Protect phones.
and i just updated my software to the latest version.

(bootlocker not done yet, i don’t know how to do that)

but still nothing.

Is there any reason IF had to do this? Or did google force this on you guys?

And FYI this is a terrible decision. It prevents it from running on some devices that are not unlocked or rooted (mostly stuff from China).

As you mentioned China… i was terribly disappointed by that since my phone is a Huwaei-made.

I’m using Samsung S8+, and i don’t have any trouble at the moment. I’m still testing with the performance of the new update 21.5

That’s one point of view you could have when only looking from one single perspective. Look at what the feature itself actually does.

Most devices should be perfectly fine, as long as they are legit. Rooting, unlocking the bootloader etc etc comes with it’s own risks which I’m sure most users that does it are already very well aware of.

Well that’s because I’m on the wrong side of this. It blocked my MI MIX2S which is not rooted or unlocked…
There are some phones out there that came with google services but not play store back in the days and these are getting blocked as well.

You might need to check that again. MIX2S is on the list of supported devices.