Couldn't land in CYYZ

Couldn’t land in CYYZ on expert server. Heard callouts till 10, noticed FPV was still around and AGL is 0ft, I sank through the runway. My airspeed increased as my MSL showed negative value and I quickly ended the flight so as not to get any violations. Does this got something to do with not clearing scenery cache?

3 Likes

Hmmm I’ve had sinking through the grand when I have spawned a few times. Clearing the cache seems to work. I recommend clearing the cache often to avoid glitches :)

1 Like

Probably just some curropt files a clear of the cache should do it unfortunately this happens every once in a while. Report back if issue is solved

1 Like

Yes you should clear your cache often to avoid those kinds of glitches 🙂

1 Like

Most likely a cache issue, if resetting it doesn’t help, shutdown your device and turn it back on again and if that doesn’t work reinstall IF.

1 Like

Will I lose my subscription if I reinstall?

No, you wont lose your subscription :)
But what have you tried to fix this?

I have the same problem… I land put I sink down and when I clear the cache it is not better

Nope! Just have to log in again.

As far as I know, I don’t have any issues.

Which runway did you use?

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.