Constant Crashing Since 21.5 Update

Since the update to 21.5, I have been unable to complete a flight. Sometimes it crashes before I ever finish a flight plan, sometimes it crashes when I use ATC features, sometimes it crashes soon after takeoff, sometimes it crashes an hour into a flight. I’ve tried different airports, some busy, some completely empty. I’ve tried different times, times of day, different regions… It crashes with third party apps running or if IF is running by itself. I’m using a 6th gen iPad, plenty of memory and battery. Never had a problem until this update. Now I can’t complete a flight no matter what I try. I can’t figure out a rhyme or reason to why it keeps crashing. Any help anyone can offer?


Hey! Try to delete the app and download again. When the update arrived maybe something went wrong on your device.

No, deleating the the app should be a last priority, Could I ask what device your using @jesse00pno?

6th gen iPad

Try taking a scroll through this and take a look at your device.

What are your current graphics settings? Lowering them may help with the crashes you are having

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.