Consistent crashing mid flight

Hi Guys!

Sorry to have to post this, but I’ve tried everything I normally recommend to folk and had no luck rectifying the problem!

Device: iPhone6S
Software: iOS 11.0.1
Nil apps running in background.

I’m unable to provide a screenshot of the issue seems it bins IF out completely. Here is a timeline of events. Each bullet is a different flight

  • known black ground issue upon final approach
  • post cruise, I started my descent resulting in software crash, IF closing and leaving me on my home screen.
  • late last night - stuck on loading screens with no joy of it finishing. Eventually gave up and decided to resolve in morning, thinking it could have been server load.
  • same issue this morning, uninstalled then reinstalled IF. Started my flight, taxyed, took off and started my climb, passed 10kft and NAV started a left turn - boom. Crashed, back to home screen.
  • the above happened again about 2 hours later.

I used to run IF Assistant (great app, highly recommend) in the background, but due to my devices/softwares vulnerability I’ve been running IF alone with nothing else.

Is there a step I’m missing or is there another post I’ve missed with a similar problem that’s been solved? Helps appreciated as always 👍🏼

3 Likes

Lowered graphic settings and plane count? Also. Is this on a particular mode (e.g. solo or live)?

Try playing while charging.

2 Likes

Been having the same issues since release but my phones a 6plus.

Tried everything and more but can’t seem to fix it… my flights seem to run smoothly until I open the flight plan and start typing in waypoints or once i start decent into an airport, switch vs, camera angles, speed etc.

If anyone has solved this issue please help us :)

1 Like

It’s run fine on the settings I’ve had until this point, nothing’s changed on my phone either - and more often than not the phones being charged while IF is running.

This may be futile but try uninstalling, clearing cache, and then reinstalling

1 Like

How much free space do you have left on your phone?

It is recommended to have at least 1-1.5 GB free just for IF

I have just over 4.5Gb free bud.

@Insertusernamehere care to teach an old man how to clear the cache on an iPhone? 😂

3 Likes

@Insertusernamehere I’ve managed that, so let’s see how that goes. I’ll leave this open in case a Mod arrives with a Gem of knowledge.

Oops sorry forgot to reply, got distracted 😑. Apple is a bit different from android so my comment wasn’t really applicable - my only other suggestion would be to try reinstalling again, but I doubt it would work, sorry.

If I had to guess what this issue was, I’d say it was your phone transitioning from low power mode where it calculates physics at much longer intervals, to standard physics, which gives your phone a “shock” as it’s workload is increased heavily, resulting in an app crashes. However this may be entirely wrong.

The same has been happening to me. i dont do flights longer than 3 hrs anymore. Sometimes it freezes and i have to restart IF.

1 Like

Yeah I’ve disabled the low power mode and it’s still happening.

I have never had any issue at all Global!! Sadly. I think it’s device linked. I have the iPad Pro 10.5.

1 Like

simply restarting your device should clear the RAM.

I’m an Android user, but is IOS 11.0.1 the latest software?

I believe so, but it’s definitely a stable software - I’m using it with no issues. Also, you can try to clear the RAM manually by holding the power button until ‘slide to power off’ appears, and then hold the home button down. I doubt it’ll help but it’s worth a try.

Yeah I’ve done all of what’s been mentioned so let’s see how I get on! I’ll update you all shortly 👍🏼

Nope, just happened again! So I’m at a loose end.

Seems to be just after I pass through 11kft every time.

Reinstalling the App didn’t work for me either. Also I’ve tried clearing RAM and restarting my phone

Do you have the exact same issue? What’s your device?

How is your connection to the server?