Challenger 350 Control Issue

Device:iPhone 14 Pro
Operating system: iOS app 16.6

While taking off for a flight, The CL35 I was flying would just not rotate. As much as I would tilt the device, the jet would rotate a maximum of 5 degrees. Additionally, when I managed to get it in the air, it would bank to the left hard. This is a great aircraft and I would love to be able to fly it. Yes, I did try recalibrating multiple times.

Hi, do you happen to know your airspeed, weight, and wind direction and speed? Or do you possibly have a screen shot with this info?

Sensitivity and trim could also be a factor

Restore your control defaults in settings, then restart your device

I was taking off at around 130-130knots, and the winds were 7knots of wind.

Takeoff at 200kts at least in this image with barely any runway left, while it should have taken off much earlier.

I tried changing sensitivity and trim was even at 30.

I will try it, but I mean it was only the CL35 that was acting weird.

It turned out, if it was that or just waiting a few hours, that resetting the controls to default solved it. Thank you!


This topic can be closed now

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.