Certain Photos won't upload to topic

Not entirely sure where to post this but I think this is where.
So here is the problem:
Some photos won’t upload onto the IFC topic such as IF screenshots and photos that I recently took when plane spotting. This only happens with certain photos. The “Processing Upload” continues to load and won’t let me create topic or do anything but cancel the entire topic. I have tried to resize my images to decrease the amount needed to load in, but it did not work. Any help in fixing this would greatly be appreciated! Thanks!

3 Likes

Just out of curiosity are you on an IOS device running (I think) IOS 13+

i had this problem too i just restarted IFC and my device and it worked for me

No. iPhone 12 Mini. Fully updated. And this problem is only on my computer

How would you restart it on my laptop?

Which kind of file format are you trying to upload? If you’re uncertain, right click the file → Properties.

I have experienced trying to upload multiple HD photos and it lags out the IFC and refreshes and never uploads.

maybe close the browser your seeing it on and try again?

JPEG is the type I use. However, snipping tool JPEGs upload with no problem.

Update: It is now working. Thanks to everybody who gave me tips or helped me!