Casual Server not Connecting

Device: Ipad 9th Generation (purchased new 2 months ago)
Operating system: Latest IpadOS

For days now, the casual server doesnt seem to work for me, and it wont connect to live mode (therefore I cannot use unicom or see other players). Flights with the casual server are also not logged, and XP/landings are not awarded, and it is not showing up in my logs

However, at the same time, the Training and Expert server DO work and load for me, as I can see other planes and interact with unicom/ATC, therefore it cannot be a WiFi / Device problem on my end.
Its quite an odd situation, does anyone have a fix? I often use the Casual server for testing out things, landings and having casual fun with others, so I don’t know what to do.

Here is what it shows, notice the top-right icon and the unicom ATC icon in the bottom left (greyed)

Does anyone have a solution? It is still not working

If you really loveeee causal server then try restarting app if doesn’t work restart device

Tried restarting everything lol. I think ill have to resort to the last option of deleting and redownloading the app, but the connection here is horrible (im not at home) and Im scared it wont even download

1 Like


Is there reason to believe this isn’t a user-side issue based on your poor internet connection, as opposed to Infinite Flight?

Try finding a better connection before we can troubleshoot app-side faults.


How come the Training and Expert servers work fine then?

Ive even ATCed on the training server, and flown with ATC and other pilots on the expert server, so they work fine. Ive redownloaded IF and the causal server still doesnt work, while other servers do

Casual Server is on different server cluster. Could be that the network you’re currently on is blocking the port or protocol used for Casual.

1 Like


There are some simple troubleshoots you can try.

  • Restart your device (you’ve already done this).

  • Switch between network types (eg. WiFi to Cellular).

  • Try another network.

  • Toggle airplane mode (shut down Infinite Flight and use airplane mode for about a minute).

  • Turn off any VPN or proxies you may be using.

  • Reset your network settings.
    Settings > General > Reset > Reset Network Settings. This will reset any WiFi passwords, cellular settings, et cetera as well.

  • Update your DNS settings.
    Settings > WiFi > Press the (i) button on your selected network > Click DNS (penultimate option) > Delete any current DNS servers and replace with new ones (Google and Cloudflare DNS attached below).

— 2001:4860:4860::8888
— 2001:4860:4860::8844

— 2606:4700:4700::1111
— 2606:4700:4700::1001

You’ll want to re-launch Infinite Flight as you go through each troubleshoot as earlier ones may work and the steps become more tedious as you get later into the list.


Ive been on this same network for two weeks, and it seemed to work at first for a few days

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.