Can't see buildings after new update but could before

I fly using a samsung chromebook pro. When the first update came out with 3D scenery, everything was working fine and as smooth as could be. Now with this update, I can’t see any of them. I tried uninstalling and trying to download it again. The app worked perfectly but with no buildings. I don’t understand why when it was working perfectly at launch why it doesn’t now.

Just to clarify, are you using an emulator alongside your device to play Infinite Flight?

Nothing. Just downloaded IF from the default google play store.

It’s basically a tablet with a keyboard that won’t unattach. I’ve been using it for years. And it’s worked flawlessly until today.

1 Like

Did you change the 3D Object Density setting?

I did some research and I guess IF is downloadable on chromebooks… Not sure really how to help you other than try turning down your settings and reseting your scenery cache

I don’t even see that as an option in settings.

Settings–>Graphics–>3D object density

I had this issue aswell on my iPad. I did a uninstall and a device restart and solved my problem. :)

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.