Can't open the app

My app is stuck on opening screen, tried everything.
Device - Ipad 7th generation
Soft reset ✔️
Hard reset ✔️
Network reset ✔️
Reinstallation ✔️

Done all of the above still no luck. Help out

Well you have done everything I would tell you to do so your bets chance is to wait for a mod/staff.

1 Like

Even tho you did a network reset it doesn’t mean it’s not the problem which causes this issue. My iPad couldn’t open IF too because of bad Internet.
You could show us a speed test of your internet so we can check if this is the issue :)

1 Like

I would suggest going to Settings > Manage Storage > Infinite Flight > Offload App

1 Like

You’ve done the regularly recommended things to do when this happens.

Something I’ll just say is maybe try to clear out your RAM. Other apps that might be running in the background I’ll say just disable. I hope that would work but it’s something you can try.

Also something to maybe think about here is your internet. Is your internet strong?


This is my new device, thanks

1 Like

Infinite Flight requires a very very small amount of Internet speed to run, so this should not be the issue.

1 Like

Tried and no luck.

Thanks but after the hard reset, IF is the only app that’s installed and running. My Internet speed is decent I think.

Hello @Varun_Bhardwaj!

You are the 2nd user in the last weeks with similar issues originating from India.
There seems to be some DNS related issue ongoing that is causing this in India, could be that you’re using the same service provider.

But the user i helped, was able to get things going by changing the DNS on his device.
As you’re using an iPad, try the steps below:

  • From the iPads home screen, tap Settings.
  • Tap Wi-Fi. The available wireless networks in range of your iPad appear.
  • Find your wireless network in the list, and then click the arrow or the “i” symbol if you’re already connected.
  • Tap the “Configure DNS” field.
  • Tap the “Manual” field.
  • Delete the current DNS servers, and enter the new DNS servers. (If you enter more than one DNS server, be sure sure to separate the servers with commas.)
  • To use Google DNS, enter and
  • Re-launch IF

Thank you, the DNS fix worked and the issue has been resolved.

1 Like