Can't Log in with WIFI

Greeting FDS,xxa,

I am having trouble issues Logging in to my account using WIFI connection at home, in the flight sim, but if ill be using my CELLULAR DATA, there’s no problem at all, I can FLY, i had this problem since July 9, 2017. If I will check my account at infinite flight website it says that im not subscribed but I subscribed last April 11, 2017 for a LIVE + 1 yr. My details & Screenshots below:

LoginType: Facebook
Call Sign : PR-033

Device: ASUS ZENFONE 3 ( ASUS_Z012D )

Have you tried resetting your internet modem/router or restarting your phone?


Simple one variable at a time problem solving:

If you can connect while on a cellular network, but not while on WiFi, the issue is the connection. That’s the variable. Restart your router, or at least ensure you have a connection to the Internet via WiFi.

Have you tried connecting to anything else while on WiFi that isn’t cached?

Connection to IF would be based on whether you’re able to communicate with the server. The method of communication shouldn’t matter.

[Edit: The post below looks promising. Try that]

1 Like

Try this, same principal but on android. It has helped a few people in the past.


Maby you should restart your router and make sure that device is connected to your router and not restricted.

1 Like
  • restart router
  • clear all background apps
  • hard reset
  • reinstall Infinite Flight

Try these steps one by one and check if it’s working again. If not, than wait a little while, it might has something to do with the servers.

1 Like

I had this issue when Live was first introduced. My wifi router settings had maximum firewall protection so it was limiting the connection to IF servers. When I reduced the settings, Live worked perfectly.

1 Like

How did you reduce the settings

It depends very much on your router. You have to check the instructions manual for your specific router to determine how to lower your firewall settings.

1 Like

Just now I can no longer fly. Im havin the same problems using Cellular Data… :( 'sad

I recommend a factory reset of your device. This sounds like some kind of connectivity issue caused by your device.

1 Like

Adding to what he said, Backup all your Files


Last recommendation, remember to pay the bills.

1 Like

You should probably shut down your device for a few minutes and reload it or you could do what @schyllberg said and have a factory reset. If possible while doing the factory reset, make sure it does not erase any important data you want to keep. Oh. And also check your wifi and internet.

Good luck! :)