Cant load the scenery

Am landing at LOWW but for some reason scenery is not loading and even cant see the RWY on the map!

I can even spawn at all, stuck in the loading screen

Hey! If you haven’t already, go to settings and clear your cache

Did! But still not working

try powering your phone off completely then turn it back on.

Am approaching!

oh, yeah then all I can say is clear scenery cache then but you said that didn’t work so I don’t know sorry.

This also happened to me today, I was on final approach and the runway disappeared…

We’re looking into this.
The issue seems to be related to our CDN (content delivery network) but we need some more time to verify and they seem to have a few issues related to monitoring right now too.

We’ll let you know as soon as we have something!

4 Likes

i just had the same problem, hope it will be solved soon. i had planned an 18h flight this night. :)

We’ve tightened a few bolts & kicked it around a bit now.

Looks like everything is returning to normal :)

5 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.