Can't launch Liveflight connect

Edit: This problem is solved

I downloaded liveflight connect couple months ago and it worked totally fine until yesterday’s flight.
However, there was an error message saying like some files were missing this morning when I launched liveflight connect. (I couldn’t remember what exactly it was saying.)
I tried to reboot my pc and it didn’t work. So I tried to re-install the liveflight connect and the webpage told me that there will be no official support for future updates but the download link is still available. I downloaded it and launched the setup.exe with run as administrator and it failed.
The following image is the error message.
error
As you can see that there was an error with the website

https://connect.liveflightapp.com/windows/LiveFlight%20Connect.application

If you click the link above and it says 404 error.

Please help me to use my joystick again.

Conditions
Samsung laptop with Windows 10 home
Thrustmaster t.flight hotas x
iPhone 8 running infinite flight
lonelyscreen for mirroring to a monitor

ps. sorry for bad English I really wanted to get some help

Interesting…I’m having the same problem too. Maybe @Cameron can explain.

I updated the download link on the website, thanks!

1 Like

Thank you! Now it is working.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.