Can't install Liveflight connect

Hi,

I just bought a Thrustmaster joystick to use with Infinite Flight. So i went and downloaded the live flight connect install for windows. But whenever i extract the setup.exe and start it, i get this error message:

Naamloos

I tried everything, but i can’t get it to work…its driving me nuts.

I also checked the install.log:

Can someone help me with this, it would be a shame if i bought the joystick for nothing. My laptop has windows 7 on it. Maybe the download on the website is a corrupted file???

Thanks in advance.

Maybe check that your aren’t downloading the Mac version. :)

2 Likes

Also you may want to contact @Cameron about this after troubleshooting.

Hi! As LiveFlight is a third party software, it is better to contact them directly, as they have no affiliation with Infinite Flight or FDS. You could also PM Cameron, but most support inquiries should be sent to this email:

contact@liveflightapp.com

Thanks for your understanding!


@jdag2004, the Mac version wouldn’t even open on a PC (unless running vbox), as it downloads in a .dmg file, whereas PCs use .exe.

David there is very helpful.
I have HOTAS X and it works but I have Windows 10.
Try going to “downloads” and click on the application.

I understand. I already sent a email about this, but because he is in his exam period, i could be waiting a long time for a answer back so i hoped someone on this forum could help me meanwhile.

I’m pretty sure queries are allowed in #thirdparty, although LiveFlight does have a support email.

Ah ok, didn’t see that post.

@Hishlubsjoo have you tried looking through the below website?

https://help.liveflightapp.com/

1 Like

Yes already looked there for troubleshooting…

I think i know what’s causing this… and it’s something Cam needs to adjust. So let him respond first :)

3 Likes

I’ve faced a similar situation like yours and deleting a folder worked for me

  • Uninstall LiveFlight Connect if you are able to do it.
  • Delete the 2.0 folder in %userprofile%\AppData\Local\Apps
  • Install LiveFlight Connect

Thanks for your help! I appreciate it. But i dont have the map apps in my local. So i cant delete anything.

Are you unable to access the folder stated by @Sumith? You could try enabling “show hidden items” in “Folder Properties” (search it in the start menu).

I can acces the folder, already opened the option to show hidden items, but when i go to the local folder, there is no “apps” folder.

Guys, i think you misunderstand the error message. It looks like the file trying to be downloaded does not exist. No local action will solve it :)

1 Like

Exactly! Thats what i thought. I think its not able to download from the server. Hope Cam will read my email/pm soon

Hmm, it says “An error occurred trying to download… [file from LiveFlight server]” in the logs.

Maybe someone has the full package setup in a other link?? Or is that not possible? 😊

I dont know if cameron fixed it or that it worked because i downloaded the setup with internet explorer instead of mozilla firefox, but problem solved!

I had the same issue. Cam knows the workaround and it worked for me, await his reply :)