Can't enter Airport ID or Flight No

I picked up my tablet to spawn at an airport (KBOS)
I switched to a Jetblue livery so I selected Jetblue then typed the flight no. 891. The keyboard just sits there. So I cant’ use the “OK” IF button to accept the new flight no. I tried all servers same thing.
Then as a test, i exited the game and typed in a new airport code KTPA…same thing I can’t select OK it. . looks like the tool bar covers it ?

I did not change any settings on my device.
It was fine earlier in the day.

Samsung Tab S7

strange ???

Hello there!

This is unfortunately a quite common issue with many applications & games since the OneUI 4.1 update. It doesn’t affect all devices, but a fair share it seems. The complication with this problem seems to be that Samsung’s OneUI 4.1 update introduces a resolution limit to games. This limitation has some pretty nasty and unwanted side effects with a ton of games, besides Infinite Flight.

There is a workaround however:

  1. If it is not already installed on your device, install Samsung’s Game Booster (Game Booster Plus - Apps on Galaxy Store)

  2. Go to “Gaming Plugins” → “Game Booster Plus” and tap the icon on the right side of the row that shows Infinite Flight & select the “High quality” option.

This should resolve any resolution related issues you may experience since the OneUI 4.1 issue.

We will have a look at our end and see if there’s anything we can do to counter this change. But we suspect that the fix will have to come from Samsung in the end.

Thank you!

I just came to say happy anniversary!

where to i find it ?

On the Galaxy store, since you operate a Samsung device.

If it’s already installed on your device which it should be, it’s among the other apps on the regular app screen where all apps are shown.

i have it installed but cant find the control screen or it

I dont see the same screen as you

describe it.

I “boosted” IF…nothing changed and my GAME BOOSTER PLUS dosen’t show IF on the right side and the option you suggested to select

So I guess now I can’t select a flight No. ?
or airport code unless i spin the globe?

This is not good !

Can’t enter and select a route now either.

My IF has been rendered useless. Because of a update ???

This needs a fix somehow


Unfortunately IF can’t fix the issue cause it not an IF issue it’s an OS issue.


So , IF dosen’t set up the game to function on the most popular devices and their OS .

I’m the only Samsung Tab S7 user on IF ???

Where is step 2. Go to gaming plug ins?

where or how do i do that ?

Where do i go to or find “Gaming Plugins” to see IF on the right side? So I can select high quality???

No you’re not!

I regularly see people having the same issue as you, which is an issue Infinite Flight Cannot fix.

Wait for Schyllberg to come back and help you.


1 Like

Check this post. Maybe it’s helpful for you:

1 Like

No. There’s been dozens who’ve reached out about this which have been solved.

You have to understand that we can’t fix this, since to text input box that appears where you input the flight plan is part of Samsungs UI and not ours. They’ve done some weird change to this that breaks it if a game isn’t configured accurately in their game booster.

1 Like

thats on a samsung phone like my note 9 , from the pic. Not a Tab S7

I did all of this now.

Now its intermittant. Sometimes its back like it was . Then I start up IF again and its not working correctly
i have the short cut bar enabled

I think I have it fixed…

Got plugins Turned on game booster plus
and went into IF. Turned “Graphics” to 100%
it was at 50% in that.

I think its ok now

1 Like