Can't control at any airport

So last night, I was trying to control at an airport that no one was controlling and I get this:

As you can see I have no control what so ever.

I’ve tried:
-Restarting Infinite Flight
-Restarting the device
-Unistalling and installing Infinite Flight but still it won’t work


-Latest IF version
device:Ipad mini 3
Version:IOS 10.2.1

1 Like

Are you positive you have a good internet connection established?

Try clicking on “tower” or “airspace”, waiting a little, then clicking the frequency bit again, try a few times

Yes I do, if I go to any other site the connection works perfectly even flying on IF live.

Already did that, waited 20 minutes with the same result

1 Like

Thanks for contacting support! This is
known but unidentified issue. From past experience a server reset will typically resolve. I’ll request that one is done ASAP. PM me tomorrow if it is not resolved!

We apologize for any inconvenience.



I’m stumped, that’s tough

Thanks for the help!

1 Like

Found the solution, deinstalled the app 2 more times and now it seems to work.Finally!

1 Like

Flagged to have it closed.

1 Like