Cannot update on android [Compatible device]

I’ve just seen Phillippe’s announcement and it says all android devices have the update now - yet I cannot update

  • Samsung Galaxy Core Prime
  • Android 5.1.1
  • OpenGL 3
  • Restart attempted

Thanks in advance

1 Like

Look for other topics as well, I believe there are similar problems for some android users.

1 Like

Tried reinstalling and alas no luck :( 😭

Currently, people are having problems with global on android and Samsung galaxy, like me.
So you may have to wait a little longer, unfortunately.

I have received the update a few hours ago on my Galaxy S6. Sometimes it takes time to Google to release an app at 100%.
Sorry John but the only thing that you can do is to wait a bit longer than others.

5 Likes

I heard that it was not going to be a release to everyone at one time like Apple was. I think it was going to be X people on X date and then Y people on Y date. (This is all over a few days). For me on IOS the update was pushed but the update button did not appear, so I deleted and reinstalled the app again and it came with the new update.

Good luck!

1 Like

I hope you can get the update

1 Like

Still no luck - I have confirmation I am on android 5.1.1 & openGL3.0, so shouldn’t be an issue there. Have cleared Google play data, and uninstalled the app. One thing to note, is that unlike Chris S’ problem, it doesn’t say “Device incompatible”, it just won’t let me download the newest version.

Most likely caused by the same thing though. Error message or lack of might different depending on device.

1 Like

I just cant find the update

If you can’t find the update it means your device is not supported unfortunately.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.