Cannot purchase subscription.

Hello all. I’m trying to purchase a new subscription on my iPad 2017 that’s running iOS 11.2.1 and the newest IF but it won’t let me. Every time I try to purchase it I get an error message

image

Do you have a good internet connection and can you log into the app store from your device?

Yes, I’ve logged into it many of times whilst having this issue

Also make sure you have a card on file with your iTunes account. And make sure if your on cellular data- turn it on for both iTunes and App Store and IF

Try restarting your device and the app.

1 Like

I’ll do that now hang on

1 Like

No, still the same error!

Try to factory reset your phone.

Okay I’ll do that now

I’ve just reset it and still not

See if this article helps.

Okay. Thank you for the help. I’ll look now

Is this your first time buying a subscription or have you bought it successfully in the past before?

I’ve bought it before

Has the poblem been solved yet @Ethan11?

Sadly not, but thank you for your help :)

Ok, but what IF version do you have?

How do you find out?

Idk, are you using IF v17.04.0?

Yes, I always keep it up to date