Cannot open Infinite Flight

I just got my new tablet. I got an Nvidia Shield Tablet K1 and the first game I downloaded was infinite flight to try it on the highest setting because the tablet was made for it. It worked amazing the first time but after that it just crashes immediately after I open it. I know the tablet can handle the graphics because it was running great before but I don’t know what caused that to happen. I am also on Android 7.0

It could be the speed of internet connection.

Try a simple restart of your device, and if that doesn’t work, delete, and reinstall Infinite Flight :).
Hope everything works out!

1 Like

Have you tried at lower graphic settings? I know your tablet can handle high graphics but it’s worth a shot.

Try closing all apps in the multitasking menu, it may be a RAM issue.

Most issues like slow performance, “lagging”, or crashes are minor and easily resolved. Below are some basic steps taken that may help resolve the issue:

  • Keep as much unused internal device memory available. 1GB is the recommended amount.
  • Always close other apps before opening Infinite Flight.
  • Keep your device fresh by completely restarting device power occasionally.
  • Disable active add or message blocking apps.
  • Don’t install unapproved apps.
  • Don’t modify, “Root”, or “Jailbreak” your device.
  • Don’t install IAP unlocking apps like Freedom or LuckyPatcher. They won’t work and can cause problems that aren’t supported.
  • Use a strong WiFi network within a relatively close proximity to your device.
  • Unplug your modem and WiFi router for about 30 seconds, then plug them back in if online “lag” occurs.
  • Disable Anti-Aliasing
  • Lower “Show aircraft count live” setting.
  • Lower Aircraft or Water graphics setting.

If you try everything above and still have trouble, check to make sure you have the latest firmware update available for device installed. Lastly, we recommend you delete the app, restart device power, then sign into the same account used to purchase the app originally to reinstall.

As a final resort, reset the device to factory settings. Be sure to back up all important data on your device first.

If you still need help or have questions, reply with a brief description of the problem. Include reproducible scenario steps and also device make, model, and current operating system version. Screenshots are welcome so we can better assist you and get you back in the air! You can also send me a PM if you have further issues.


I got it to work for now but I will try to not have more issues thank you to everyone that helped out