Cannot fly global

I am using the Samsung Galaxy tab A 2016 running on android 5.1.1 but it is not updating to global?

Please Help

Please take a look at the following post to see if you device is up to standards,

If you follow the link on the topic you’ll be able to see if your device is supported or not

1 Like

Several others have reported this, including me and @Chris_S. It seems to occur only on Samsung devices

I think Chris said it was a cache issue and a reinstall works if you can if not check the device requirements and refresh the play store

Hello there!
From what I know global came out 2 days ago, I got it this morning.
I hope I am not spreading false information (excuse me if I am) but I believe Google play has a way to release things, it gives the update (in this case IFG) to a certain amount of people, then hoping all goes well gives it out more and more until everyone who has the app got the update. You may get the update later today/tomorrow

1 Like
  • I meet the requirements
  • Have cleared cache
  • Restarted phone multiple times
  • Uninstalled and reinstalled IF

No luck :/


It doesn’t matter if you don’t meet the requirements, it will still show up with an update just saying “not compatible with your device”

1 Like

I’m no Android guy but that sounds like you’ve done everything and it’s still not working have you got enough storage? That’s a big issue

1 Like

It doesn’t show the update is the thing, it’s just not an option to update, which shouldn’t be related to compatibility or storage

1 Like

On the Google play page, do you see updated screenshots for infinite flight?


So it’s just that it’s not been pushed to your device then as someone said above they’ve only just gotten the update that this morning

Yes I doo see an updated screenshot

Ah but I see the new screenshots and trailer and presume the OP does too

1 Like

But it doesn’t come as you being able to update?

Google play doesn’t allow us to have a separate listing (different screenshots) for older version. If you do not see the new Release Notes then it means that your device doesn’t meet the requirements: if your device has at least Android 5.0 then it most likely means that your device do not support OpenGLES 3.0.

Samsung (and other android device manufacturer) makes our life miserable since the same device might have different CPU/GPU depending on where it is being sold.

Reply with your exact model# (for samsung it should be written on the back of the device, starting with “SM”) and I can confirm if it should be supported of not.

SM-G361F is the model :) It says it has openGL3.0 :/

SM-T230 is the model of my device

1 Like


It worked with the beta version…I have OpenGL 3.2 and Android 7.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.