Cannot connect to global

Trying to connect to global however it’s not connecting at all, just being stuck on loading screen…any help would be much appreciated. Tried closing app and reopening and deleting and reinstalling

Hello!

Is it the loading screen when trying to spawn you’re stuck on?

1 Like

Hello! Yes, it takes some time to load the main page but then just gets stuck on the spawning page

Thanks.

What kind of device do you have?
As you’ve already tried reinstalling, we can assume it’s some sort of connectivity issue. It works fine from here, so it’s most likely localized.

iPhone 8 iOS 11.4.1, my WiFi seems fine with the laptop and general phone connectivity as I’m talking now using the WiFi on the mobile

Could you try on cellular?

Just tried on cellular and it’s doing the same

Okay…
I doubt this will help, as you’ve already reinstalled but would like to try before taking more drastic measures.
Please try this, in the specific order:

  • Relaunch Infinite Flight (make sure you stop it from running in the background first)
  • Before starting a new flight, Go to Settings —> General —> Tap “Clear scenery cache”. It’s in the bottom.
  • Start a flight (try on Solo first)
3 Likes

Thank you for your help!

I’m going to assume it worked then? @JamieArscott

1 Like

Yes thank you, I did

1 Like