Can’t reply to ATC commands.

I was on the approach tune at heathrow when I couldn’t react to ATC commands. I left the game because I didn’t want to have any trouble. Anyone had this before?

Expert server.
Approach London Heathrow.
Happened 10 minutes ago.

1 Like

Once it happened to me and i got ghosted

Was it to all commands? Or was it to one command?

Every command

There have been similar issues like this recently I suggest you change your callsign to NORDO in the future and divert to a different airport :)

1 Like

I could only answer one command in the beginning.

This happens to me sometimes.

Have you tried tuning in from the map by clicking on the airport you’re landing at?

I could tune in but not answer.

1 Like

Oh, I see.

Have you perhaps gotten a phone call or exited the game?

Nope, but I may have checked my battery percentage. Maybe that is the cause?

Nope, I don’t think so. I check my battery percentage all the time but I can still play normally.

Also you did the right thing by ending the flight. Better to be safe than sorry!

This was my first time encountering it. Weard. Maybe a mod knows why.

Did you have a stable internet connection?

Yes I did.

1 Like

Hmm, interesting. Can you provide the replay? If so, then use this website:

Mine experience was not be able to tune to the active frequency, as my atc log is showing unicom but the ATC kept sending me warning message.

So I disconnect the internet for few seconds then back again and it solved!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.