Can’t load into a flight

Hello. I’m having an issue with the sim. When I try to load into a flight, the loading screen is just stuck on connecting and won’t log me in. I have been waiting on the “connecting” screen for 10 minutes and I still can’t load in. Can anyone help?

iPhone 7
IOS 12
Not Jailbroken
My internet has been a little wonky lately but I’ve still been able to load in fine until now.

I am having the same issue as well. Glad it isn’t just me.

1 Like

Count me in as having the same issue

Try Relaunching Infinite Flight. Then clear your scenery cache. I’m sure the mods will answer this.

There’s already another topic like this

I have to no avail. I think it’s server issues.

1 Like

Same issue is happening here.

I posted this before the other one was made.

If this is happening to everyone, maybe there is a problem with the Live Servers. Maybe they are down.

Same thing for me- must be on server end.

Wasn’t paying attention,but same thing happened to me I tried reinstalling the app and I can’t connect

1 Like

It now says subscription is now required. Which is really weird.

Okay… something is apparently up (or down).

Looking into it now!


Huh, it happened to me just now also. There is obviously a problem with the Live Servers.

1 Like

It seems to work again! Just reload the app and reconnect!

1 Like

Yeah, its working again for me too :)

1 Like

Still not for me.
I’m now having a subscription verification issue.

Its working again. Thanks!

Working for me as well

Reload the app and reconnect. It should work.