Can’t contact Tower

I’m currently flying in circles around Hong Kong and I’m not able to contact tower to land. I would really like to fix the problem without having to end my flight

Hello!

Could you please try tuning in to tower by clicking on it (on the map) and then clicking “tune in”?

3 Likes

We have seen this before, with other airports. It’s a known issue - you need to be quite close to the airport before you can see the Tower frequency.

Follow @Starley’s suggestion.

1 Like

When I was approaching Hong Kong a while ago, even when I clicked on the airport all that was showing up was a controller on Ground frequency. I flicked the WiFi off on my device for a few moments (until I got lots of red ! marks in the IF status box) and then turned it back on. Once my device reconnected to the Live Server I was able to get ATIS and Tower as well.

1 Like

Hello, I’ve just circled around in Hong Kong too and was on finals and the Tower option will not appear even when I clicked on the airport. The tower kept on telling me to contact tower on frequency. So I had to end my 12 hour flight as I didn’t want to risk being reported. Only Ground frequency was showing up.

No, click on the airport in the map and click on tune IN the map. Don’t click on the airport and go back to your list with frequencies.

image

Click on those buttons to tune.

I tried that but only ground showed up…thanks though

1 Like

Well then maybe tower was not active?

Yeah this is exactly what was happening to me… I kept circling for 10-15 minutes went 60 miles from the airport then came back and finally tower and ATIS showed up

I’m pretty sure I was close enough but thanks

I’ll definitely try this next time thank you very much!!

I tried that but didn’t work… only ground was there

Yeah, was a weird one… only had ground, but tower and ATIS didn’t appear, thus I wasn’t able to tune into Tower neither ATIS. Tower tried to contact me and there was no way for me to contact them. It’s only happened to me once so maybe it’s a glitch or something. I did check my WIFI signal and it was full bars. But anyway thanks for trying to help guys.