Belfast City (EGAC) Airport Glitch

When I try spawning into EGAC it loads me up at the gate. But then my aircraft begins falling through the ground at more than -7000fpm. Not sure if this is a known bug yet, but tried spawning in at a different gate instead and they all do the same thing.

Device: Iphone 5
IOS Version: 11.2.2

Corrupted files just reinstall the app.


Have done this and every other airport loads in fine.

1 Like

This must be a bug to yourself as I spawn there frequently and don’t have they bug.

Exaclty what spawn point? or is it all over?

@schyllberg all over the airport.

1 Like

Works fine here.
I can’t tell you why it only happens to you…
But, remove the app. Restart your iPhone and reinstall. I don’t 100% trust that a reinstall without restarting clears out everything…

1 Like

I tried all the gates

Gotta be a corrupted terrain file, reinstall the app and if that doesn’t work, come here. I’ll spawn in there now to see if it works for me.

Seems to be all good for me

This sometimes happenes to me aswell. I uninstalled and reinstalled the app, that fixed everything.