Autopilot Calibration Issue

When ever I am on Final and calibrate and disengaged the Autopilot the plane starts to stall please help me with this issue please!!


Before you calibrate your device do you use trim

1 Like

What is your speed and which aircraft?

1 Like

@anon58665202 Make sure to calibrate before tuning off the autopilot. Hope this helps.

  • Approach the runway on final with a low VS.

  • Hold your device nice and steady for the landing and hold your position.

  • Pause to the menu quickly to reach out the calibration opinion, while holding your position of your device.

  • Keep holding your position and gently press the autopilot button off. Your plane should not drive crazy and stall the next time.

  • Also make sure not to approach too slowly, no matter what aircraft.

1 Like

If possible use an iPad/tablet if you have one as the case acts nicely as a holder that will remain in a nice position as you calibrate and disconnect ap.
could always use a phone holder like the sticky ones for use on windscreens as that would do the same thing with your device.

Omg I have had the issue for a very long time they should add something like auto calibration or something because it gets annoying when your on final and turn off AP the calibration ur at is either too high or too low making you pull up too high causing you to stall or nose dive this happens to me 75% of my long hauls

I’ve had this happen too. I calibrate and my plane just pitches straight up.

1 Like

@Altaria55 you both need to learn how to set up the trim. It’s not that you are calibrating the device too high or low. It’s that you are calibrating the device for neutral pitch and roll which the aircraft is not doing at the time you disconnect the autopilot. Calibrate the device sure but before you disengage the autopilot make sure there is no pink line above or below the trim percentage. Then hold the device where you calibrated it and wala problem solved.


That’s what I do. Still happens regardless.

You are doing something incorrectly I can promise you that 😉

are you sure you are trimming correctly?!

what aircraft?

what was your airspeed before you disengaged autopilot?

what was your vertical speed?

flaps at what number?

heavy aircraft?

The trim line thingy in the settings right?

No the trim while you’re flying.

1 Like

Trim was my Issue it’s not stalling now thank you so much everyone!!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.