AutoNAV (Altitude)

I just started using LiveFlight Connect and I’m having a problem with the AutoNAV feature.

When I set a flight plan or choose one from FlightPlanDatabase without any altitude or airspeed AutoNAV words perfectly but this way I have to input airspeed and altitude to the autopilot as I am flying. When I choose a flight plan with a set altitude and/or airspeed, my aeroplane goes crazy (pulls up violently, stalls then corrects, over and over)😕. Am I doing something wrong or is there a solution to this problem?

2 Likes

@AR_AR should be able to help, perhaps PM him?

Cam can’t do much. AR wrote the code

3 Likes

Didn’t know that, just assumed it was cam . :)

I think that this might help you

4 Likes

I’ve already read this and it didn’t help 😕. Thank you though 😊

I’m sorry to hear that

Please post a screenshot of the flight plan in live flight connect as well as your speed and altitude when activating autonav.

This is the flight plan I chose fron database:

Me taking off manually:

And the moment I turn on AutoNAV:

Thanks I will try to recreate it and get back to you.

An other time
FPL from database:
image

Takeoff:
image

The moment I turn on AutoNAV:
image

And thank you for taking your time :) @AR_AR

I am able to reproduce the issue and I think I know how to fix it. Will try to test out a fix tomorrow.

2 Likes

It usually happens when retracting flaps on autopilot, the aircraft pitches up to maintain the set v/speed due to reduction of lift then recovers later.
I would advice you to keep your autopilot off until flaps are retracted

Thank you for the advice, :) I tried it. Unfortunately that’s not the problem it will keep behaving this way for a long time untill I turn off AutoNAV.

1 Like

I think I have improved this for you. If @carmalonso releases it you can give it a try.

Fix:

4 Likes

Thank you. I got the update and now it works perfecly. :-) thank you fore your help @AR_AR and everyone else :-) :-)

2 Likes

Glad it worked. Thanks for letting me know.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.