ATC on Training Server not loading then crashes

Hi there,

When I load into ATC on training server it doesn’t load the ATC control screen just shows the tower cam and then the app crashes after a few seconds.

Assume this maybe a known issue but just wanted to know if there is a fix?

Thanks

Does this happen every time?

This has happened to me a few times but it doesn’t crash, I just close out of the app and then try it again and it normally works

1 Like

this happens when you get into atc when someone already is

1 Like

Ah it said it was available

1 Like

Yeh it just crashes, multiple times too

When you join at the same time as someone else, one of you will load in slightly faster and the other should be an “observer” where you watch the ATC. Sometimes it just kicks you out instead.

1 Like

Oh haha well my app completely crashed

1 Like

Whoops— that’s what I meant by kicking you out.

Anyway, It used to be worse. Instead of crashing, when you exited and tried to join another frequency, it would say that you’re still on the other frequency as an actual controller. To get onto another frequency at the same airport, you would have to go to a random frequency at another airport to “clear” it. That only worked half the time. One time it took me 48 hours to get it working again. 🙃

I prefer the crash…

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.