ATC observer Mode

Device: IPad mini 6 and IPhone 13pro
Operating system: iOS 15.5 and iPad OS 15.5
My account is stuck on observer mode, for some reason it won’t let me control any airport. Any suggestions would be helpful. Thanks.

I am running Wi-Fi and Cellular data, and can fly just fine on training servers and am loading other aircraft just fine, but when I switch to the ATC menu, the top right says observer. Even when selecting a remote airport no one has ever heard of. I have restarted my phone and iPad, no fix, my router has had a reset since the issue and no fix. Also I am not running a VPN or running anything that will block this from working. Have tried other networks (other Wi-Fi points, public and private). I’ve signed out and back into my account to see if that fixes the issue. No luck at the moment.

Any other tips would be nice and appreciated. Thanks!

Hello,

Are you choosing and airport that already has ground or tower. Because the reason you are stuck in observer mode is because someone else is controlling that station.

Hope this helps.

Cheers!

-Ryan

3 Likes

What server are you trying to control?

As an observer you can only control airports on the training server, to get promoted to further ranks for ATC you will need to apply for the IFATC program. If you are accepted into IFATC you can start to control airports on the expert server.

Here is the topic for IFATC recruiting:

I’m trying to use the Training server

I’ve tried airports like KDFW and Kansas City Intl which almost never have people controlling them. I’ve tried a ton of airports in the DFW area just to see if it will let me and no luck.

1 Like

I’ve tried airports that do not have people, like KDFW and KDAL and many more. These locations almost never have anyone controlling them.

1 Like

How many frequencies are you selecting?

Maximum frequencies that can be selected

Local - 2
Radar - 2
Center - Whatever center frequencies are in range

So, just to condense everything we’ve gathered,

You are on the training server, not the expert server. Double check on the main ATC menu, I’ve done this before by mistake.

You’re not choosing an airport that has a controller or is likely to have one join at the same time.
Try a very random remote airport that nobody would have a reason to want to control. It’s very common to join a position that appears open just after someone else. So while you saw a clear spot, checked the empty box to control it, so did someone else, just a little faster.

If you can verify you’re choosing the training server in the bottom left of the ATC menu and you’re choosing a random airport I’m not sure what could be going on.

I recall when I played a year or so ago, I would have issues connecting when I’d play on wifi, close the game, and then play on mobile data. Try force stopping the app. If that doesn’t work try restarting your device. If that doesn’t work then this is a support issue that someone from the inside will have to handle.

And from the depths of the IF community archives I’ve found her.

This seems to be the same issue I was having.
Are you using a VPN? I believe that was my issue this time. I’ve also got another topic about another issue I was having that I mentioned in my last reply but that doesn’t seem similar to yours like this does.

I’ve only selected like 1-2 max. At airports that I’m 100% sure are NOT occupied by someone else.

1 Like

I’m on wifi and cellular, no VPN.

Yes I’ve troubleshooted everything network wise. Got the check in the top right says connected. Can fly on training just fine. Both devices restarted. Deleted the app and re-downloaded. Reset all settings and no luck.

Actually this has happened to me before and I didnt know why

1 Like

Hmm, ok. Never seen this before.

1 Like

Yeah, it’s weird. I got it to briefly work then it kicks me back to observer with no control. Few hrs later works fine but still says observer…

You should be able to control on the Training Server when you have the observer role