ATC not working

Hello, I was trying to do ATC for my training and the map does not show, I can’t see who is around my airspace. This has never happened. I tried opening another session at another airport and the issue is the same

1 Like


I had the same issue some time ago.

  • The quick and easy solution should be to leave the session, restart your device, and start a new session.

  • The long-term solution that helped me fix the issues was clearing the scenery cache and deleting any unnecessary replays. I have not experienced that issue since then.

1 Like

Could it be an internet connection issue?

Nope I don’t think so

1 Like

Will do, thank you

1 Like

I am having the same issue

It didnt work

Yeah I tried all of that and it still dousnt work.

They need to fix

There is currently an issue going on right now on Training Server that impacts ATC and flying. Hopefully, staff will find a solution soon!


Alright good to know, hopefully it gets fixed! Take care

1 Like

Hello @Jesus_Gutierrez , I keep on controlling on Training server and this issue I know, the easy fix to this just restart the session.

1 Like