ATC Ground Control Starts Completely Zoomed Out on Map

Aloha Guys,

Curious as this is a setting that I have screwed up or if there is a purpose to this.

When I first go into Control Ground the map is completely zoomed out, as in I can see half the globe when I click on the “Ground” Tab to access the ATC menu.

When I select Tower for example the map starts nicely centered around the airport and you don’t have to zoom in like crazy to view it.

Does this make sense? Sometimes when entering a new airport as ground and people start calling up immediately it is frustrating to have to panic zoom on the map to find the airport and see who is calling.

Not a huge issue, but mostly wondering if I have a setting screwed up?

Thanks!

2 Likes

I have this issue when I control. Not sure if they are aware but it’s just not you experiencing this.

1 Like

Glad it’s not just me.

Like I mentioned, it’s not a big deal at all. Just annoying at times.

1 Like

Me too 🙋🏻‍♂️

Hey! Thanks for the report!

Yes, we have this one logged and will adjust it to have a more reasonable zoom level :)

6 Likes

Awesome, you guys are the best!

Enjoy the rest of your week.

1 Like