Area-Specific Game Crashes

I’ve noticed that certain areas of my game are like no-fly zones, and when you fly into them the game just crashes. I first noticed this about a month ago. In approximately a 4 nm radius around ZHHH, my game would crash. If I tried to spawn, it would either stay stuck on the loading screen or crash a second after spawning. If I flew in, at around 4-5 nm the game crashed. So I avoided that for a while and it worked nicely. Then, I flew out of KDFW bound for the eastern seaboard about 2 weeks later. Around 60 nm NE of KDFW, my game crashed. So I tried again. Game crashed at around the same place. So I cleared the scenery cache. It worked for a bit, until I tried TJSJ-KDFW about a week ago and it crashed around KTPA. I tried spawning there and, of course, it wouldn’t work. So I completely reinstalled the game and it seemed to fix it. Then, this morning, around 150 nm NW of KJFK bound for KLAX, my game crashed again. I tried the flight again. Same result. I’m not sure if anyone else experienced this, but I just wanted to see if y’all had any insight.
Device: iPhone 6S bought in early 2016
iOS 11.3.1 (Or whatever the most recent one is)
I restarted and cleared RAM before.

Have you got the settings lowered and have you reinstalled it again and restarted your device?

1 Like

My settings are always low because I fly a lot on portable batteries, I restart before every flight, and I’ve reinstalled twice.

1 Like

You may have to lower your graphics settings, disable anti-aliasing and lower the aircraft count. You can fine tune these settings to see what works best depending on the level of detail and traffic in the area you are flying in.

1 Like

I’m not sure if it’s the traffic (because there was none) and all my graphics are already way low, plus I was flying on night time so the scenery can’t be seen

Have you updated to the very latest IOS version.

1 Like

Yep, I have iOS 11.3.1

  • Have you cleared your storage space?

  • Do you have any apps running in the backround?

1 Like

It’s only about 20% full and yep

It is possible that you may need to hard restart by holding the power button located top right and holding the home button located at the bottom center for 10 seconds at the same time. (Do not let go until your screen turns off completely the Apple logo should appear shortly after) If that does not work reset all settings by going to Settings -> General -> Reset -> Reset All Settings that should be able to solve it if not you may need to back up all of your data and Reset completely by going to
Settings -> General -> Reset -> Earase all content and settings (do keep in mind if you do not back up you will lost all data in contacts such as contacts and apps) also ( please only utalize this if all else fails and as you have stated above that seems like that is the case but before earasing completely try the reset all settings first

I suspect this is due to corrupt terrain data, as I have experienced crashing at the same region over and over again before I reinstalled the app.

For now, I suggest to go into IF > Settings > General > Clear scenery cache. If possible, restart IF after clearing the cache. If it does not work, reinstall IF and the problem should be fixed.

Cheers

That’s what I thought as well but the OP stated they have tried it numerous times before and it did not change

I know in pervious version it would crash around South Pole airfield but that coulda been patched by now.

UPDATE! I honestly don’t even know what causes this, but clear scenery cache moves it to another location so it can harass me some other day. I don’t know if this is my phone or just a bug but this topic can be closed now

Glad it got resolved!