APPR Mode -- and Autopilot in General is BROKEN

Personally I don’t experience the issues you wrote at all. I only experience the APPR one. Other aspecta of the autopilot for me are all good. And for the throttle going 100% monitor it manually then

Edit: well then make a feature request for an improved A/P

I am having an issue right now! my AP is sending me to hdg 230, and the LNAV is around 170, and it doesnt matter what I do, it is broken

1 Like

Honestly I could copy paste this or change the topic to features and I wouldn’t need to change anything except maybe the “Discuss below. Lol.” part and maybe be a bit more definitive in what I’m asking for.

1 Like

This might be because you have NAV1 enabled instead of GPS…


That was it, idk how it happened, thx

1 Like

I do agree with what you have said here. APPR has definitely improved recently, but I found LNAV has got worse. I find that I end up flying in circles way too much. And no, I haven’t got too sharp turns. I can do it fine myself in heading select, but LNAV waits too long. Autothrottle has always been like that.

I think we should continue discussion here though:



that last i used APPR was like 3 months ago
I pretty much always do a RNAV or Visual

Never noticed that topic, thanks.

I get that development takes time but… jeez. Almost three years and nothing from devs about implementing a feature that is highly voted for. :(

Some people like to use ILS approaches, like me.

1 Like

I think they have smoothed out APPR. It’s just a few glitches here and there. As for LNAV, I think they “smoothed it out” in V20.1 but it didn’t work as intended.

1 Like

The biggest issues I have are LNAV throwing you way wide of your path instead of turning you sooner. VNAV has worked awesome for me, it’s my favorite new feature besides SIDs and STARs. APPR is definitely smoother than it used to be but it still isn’t enough in my opinion.

1 Like

Do your planes turn very violently during cruising from waypoint to waypoint?

1 Like

It depends. Sometimes, yes, with lighter aircraft like 737s, A3–s, etc. Not so much with the heavier planes, but I have had that issue with the A350 and 772. Also depends on the angle, usually the more acute the angle, the more harsh and wide the turn.

I’ve found that reducing the sensitivity of the roll in controls settings can help with that – but that is a cludgy solution at best.

1 Like

See this is why I don’t trust computers. But in today’s world they are unavoidable, so I was forced to make a compromise. I don’t use autopilot below 3000ft AGL, unless I am confident that the aircraft will keep stable and not make any aggressive maneuvers (which is why I am phasing out using infinite flight’s APPR feature because it really really sucks and it needs a ton of work). I am more confident with some aircraft than others to fly safely and comfortably, but regardless, I try to use the airplane’s computers (autopilot and APPR) as little as possible, because like I said you shouldn’t trust computers.

I have had no problems with APPR mode for months…so clearly you are doing something that you shouldn’t be (ie going too fast, too high etc…)


I might just address a few of your points here, because I use APPR each time I fly an ILS approach to capture the localizer and I have not had any issues with it aside from when I had not configured it correctly.

Yes 30 is the limit but I try to aim for no more than 15 to be super sure.

First of all, APPR cannot control speed. There must have been something else going on here. Perhaps a replay share is in order? Furthermore, APPR will not correct altitude until it is established on the glideslope.

I understand your frustration, however take a step back here. The people who code these systems are fantastic at what they do, there is no doubt about that. However they are not aircraft engineers, and they are working on a mobile simulator here - performance has to be considered.

Consider the alternative. If autopilot needs to throttle back as it approaches it’s target speed, then aircraft performance needs to be taken into account to avoid over compensation. That means individually programming the autopilot for each aircraft which is very time consuming.

As above. Doing this would need to consider aircraft performance meaning each aircraft’s autopilot needs to be made individually leading to an even longer time from starting to create an aircraft to release.

Same issue. See above.


Please remember these functions do work. And the alternative is an even longer development process. Laura has said before autopilot was one of the hardest things to make, so this could well add a month plus to aircraft production.

If you’re sure it’s a consistent issue, see Maxim’s post below.

I hope I’ve answered some questions and if not excused the quality of the current autopilot then at least explained the likely reasoning behind its current state.


You post a topic about an issue that is bothering you, yet I can’t find any details like your replay, flight parameters etc. I’m not sure how you want us (and the developers) to help you without including this information? For all we know it might be you who is incorrectly using APPR (you have to admit, this is a possibility from our side).

If you want something to be done about this, more details are needed. In particular, can you reproduce this issue with certain settings? For example:

  1. Select thisApproach at thisAirport
  2. Have thisAmountOfWeight
  3. Fly at thisSpeed KIAS
  4. etc etc…

By reproduce, I mean can you consistently (every time) fly the same approach, with the same settings and get APPR to ‘mess up’? If you can, post below and that’ll be of great value to the developers. Saying that “APPR is broken” isn’t very valuable as a statement by itself.


I want to make it clear that I’m not looking for help specifically. That’s why this isn’t in support.

I wouldn’t be making this topic if it hadn’t had happened to me multiple times under the same circumstances. Granted, SKBO is at a very high altitude! That could have something to do with it.

I could be using APPR wrong, but I’ve said what I’ve done to activate it in my original post and haven’t heard much of anything telling me I’m doing something wrong.

My point is that APPR and Autopilot in general is not as good as it should be right now. In my opinion, they have had ample time to at least make some small quality of life improvements. They must be taking into account some factors, like speed, because of how it anticipates for turns.

1 Like

Hello, please take a look at the topic I made about this a few weeks ago:

From what I’ve found, it happens when your sensitivity is jacked up way to high. Try resetting it through your settings, and see if it helps!

Here’s the replay file from the flight I most recently had issues with.