App won’t open despite redownloading mulitiple times

Problem: I have restarted my device and redownloaded multiple times yet it won’t even open. I press on the app and it goes black screen then back to the Home Screen. Is there anyway to fix this.

Device: iPad Air 6th gen
Operating system: ios 15 smth rather


Before it crashes, are you getting an error code?


Nope it doesn’t even show the logo yet.

If it’s crashing immeditaly upon launch, there’s something that corrupted the installation.
You said you’ve tried reinstalling - I would however like to suggest doing so again but with one additional step:

  1. Uninstall Infinite Flight from your device
  2. Restart your device
  3. Reinstall Infinite Flight from App Store.

This is happening to me too, would I offload it or fully uninstall?

Fully reinstall.
Offloading is not sufficient.


Ok thanks!

Thanks! This worked, didn’t know this was the fix after having to use my phone for over 2 years.

1 Like

I did offloading with restarting as well that didn’t work so I’ll try fully deleting the app and then restart and download the only thing is I will lose replays but thx tho.

It Worked :)

1 Like